Earlier this week I encountered a PosKeyError. This is in a Plone site with RelStorage (postgres). The traceback pointed to a DateRangeIndex. In the end I solved it by removing this index (the effectiveRange index) and recreating and indexing it.

So: problem solved, but I wonder if it is likely to happen again. Has anyone seen this problem specifically in a DateRangeIndex?

Here is the last part of the traceback, happening on every page, at least for anonymous users, because it happens when building the navigation:

Module Products.PageTemplates.Expressions, line 125, in render
Module Products.CMFPlone.browser.ploneview, line 67, in globalize
Module Products.CMFPlone.browser.ploneview, line 124, in _initializeData
Module Products.CMFPlone.browser.navigation, line 179, in topLevelTabs
Module Products.CMFPlone.CatalogTool, line 421, in searchResults
Module Products.ZCatalog.ZCatalog, line 663, in searchResults
Module Products.ZCatalog.Catalog, line 738, in searchResults
Module Products.ZCatalog.Catalog, line 477, in search
Module Products.PluginIndexes.DateRangeIndex.DateRangeIndex, line 288, in _apply_index
Module ZODB.Connection, line 797, in setstate
Module ZODB.Connection, line 837, in _setstate
Module relstorage.storage, line 470, in load
POSKeyError: <ZODB.POSException.POSKeyError instance at 0x17910f80> (Also, the following error occurred while attempting to render the standard error message, please see the event log for full details: 0x68b741)

This is a Plone 3.1.7 site that has been moved to RelStorage (1.5.0) earlier this year. Zope 2.10.12, ZODB3 3.7.3-polling, python 2.4.


Maurits van Rees: http://maurits.vanrees.org/
Zest Software: http://zestsoftware.nl

For more information about ZODB, see http://zodb.org/

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to