Seeing that this is a rather annoying/irritating problem, and I would *think* 
it would affect a *lot* of people (anybody needing java?), are there any better 
plans to fix this than asking the customers to do a kludge/manual fix every 
time they make a new zone? Sorry for the negativity, but I've been pretty let 
down by the whole bugfix/patch scheme with Solaris and JES. It really doesn't 
make for a positive view of Solaris when on a clean install/smpatch'd to the 
max, installing *Sun*'s own software on *Sun*'s own OS, doesn't work.

Thanks,
David

PS -
# cd /usr
# rm -rf java
# ln -s jdk/jdk1.5.0_06 /usr/java
# ls -ld java
lrwxrwxrwx   1 root     root          15 May  9 11:13 java -> jdk/jdk1.5.0_06
#

It (Studio 11) seems to be installing fine now. 

----- Original Message -----
From: Enda o'Connor - Sun Microsystems Ireland - Software Engineer <[EMAIL 
PROTECTED]>
Date: Friday, May 5, 2006 0:05 am
Subject: Re: [zones-discuss] studio 11/zones/weird issue with java

> Hi
> I suspect you are hitting
> 6377605 "GNOME pkg breaks /usr/java link non-global zone in Solaris 
> 10 
> 1/06" is the one for you,
> 
> I'd suggest creating the usr/java link in the zone the same as it 
> is in 
> the global zone
> 
> 
> Enda
> 
> David J. Orman wrote:
> 
> ># ls -ld /usr/java
> >lrwxrwxrwx   1 root     other         15 Apr 13 20:17 /usr/java -> 
> jdk/jdk1.5.0_06># zlogin zone7
> >[Connected to zone 'zone7' pts/3]
> >Last login: Thu May  4 13:20:39 on console
> >Sun Microsystems Inc.   SunOS 5.10      Generic January 2005
> ># ls -ld /usr/java
> >drwxr-xr-x   3 root     root         512 May  3 11:50 /usr/java
> >#
> >
> >This is the zone I installed in my previous email, long after the 
> patch was applied to supposedly fix this issue. :) I really 
> appreciate any help you can give me on this!
> >
> >Cheers,
> >David
> >
> >----- Original Message -----
> >From: Enda o'Connor - Sun Microsystems Ireland - Software Engineer 
> <[EMAIL PROTECTED]>>Date: Wednesday, May 3, 2006 11:24 pm
> >Subject: Re: [zones-discuss] studio 11/zones/weird issue with java
> >
> >  
> >
> >>Hi
> >>Is /usr/java link in the whole root zone a valid link ie
> >>
> >>what does ls -ld /usr/java say in the local zone?
> >>it should be the same as the global zone, but in whole root zones 
> >>in 
> >>update 1, the link was broken due to issues with java and gnone.
> >>
> >>
> >>Enda
> >>
> >>
> >>David J. Orman wrote:
> >>
> >>    
> >>
> >>>Well, the "fix" mentioned didn't work. :) This is:
> >>>
> >>># uname -a
> >>>SunOS server2 5.10 Generic_Patch_118844-30 i86pc i386 i86pc
> >>>#
> >>>
> >>>All patches suggested by smpatch have been installed. Including 
> >>>      
> >>>
> >>the patch with the "fix".
> >>    
> >>
> >>># showrev -p | grep 119415-05
> >>>Patch: 119415-05 Obsoletes:  Requires:  Incompatibles:  
> Packages: 
> >>>      
> >>>
> >>SUNWgnome-a11y-libs, SUNWgnome-a11y-libs-share, SUNWgnome-a11y-
> libs-
> >>devel-share, SUNWgnome-a11y-libs-devel
> >>    
> >>
> >>>Yet:
> >>>
> >>># zonecfg -z zone7 info
> >>>zonepath: /export/zones/zone7
> >>>autoboot: true
> >>>pool:
> >>>net:
> >>>       address: 66.91.129.189
> >>>       physical: e1000g0
> >>># zoneadm -z zone7 install
> >>>Preparing to install zone <zone7>.
> >>>Creating list of files to copy from the global zone.
> >>>Copying <131400> files to the zone.
> >>>Initializing zone product registry.
> >>>Determining zone package initialization order.
> >>>Preparing to initialize <1053> packages on the zone.
> >>>Initialized <1053> packages on zone.
> >>>Zone <zone7> is initialized.
> >>>Installation of these packages generated warnings: <SUNWgnome-
> a11y-
> >>>      
> >>>
> >>libs-share>
> >>    
> >>
> >>>The file 
> >>>      
> >>>
> >></export/zones/zone7/root/var/sadm/system/logs/install_log> 
> contains a log of the zone installation.
> >>    
> >>
> >>>#
> >>>
> >>>Thus, still no working Studio 11 install inside the zone. Any 
> >>>      
> >>>
> >>other ideas? This is a bit frustrating, I can't complete 
> migration 
> >>of services until I can compile the ones I need. ;)
> >>    
> >>
> >>>Thanks,
> >>>David
> >>>
> >>>----- Original Message -----
> >>>From: [EMAIL PROTECTED]
> >>>Date: Tuesday, April 18, 2006 10:55 am
> >>>Subject: Re: [zones-discuss] studio 11/zones/weird issue with java
> >>>
> >>> 
> >>>
> >>>      
> >>>
> >>>>>http://corenode.com/~ormandj/files/install_log
> >>>>>     
> >>>>>
> >>>>>          
> >>>>>
> >>>>Thanks, that confirmed my suspicion.  Although it's a GNOME 
> package>>>>that is producing an error, it ends up causing a later 
> Java error
> >>>>downstream.  The relevant bug is
> >>>>
> >>>>  6340516 wholeroot zone install generated warnings for
> >>>>          SUNWgnome-a11y-libs-share
> >>>>
> >>>>It's fixed in revent Solaris Express builds as well as the 
> upcoming>>>>Solaris Express release.  It's also supposedly 
> addressed in the
> >>>>following patches
> >>>>
> >>>>  119414-05 or later (sparc)
> >>>>  119415-05 or later (i386)
> >>>>
> >>>>although since the fix is to correct SUNWgnome-a11y-libs-share's
> >>>>dependencies, I'm not sure if this is fixed by applying the 
> patch to
> >>>>the global zone.
> >>>>
> >>>>dsc
> >>>>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>_______________________________________________
> >>>zones-discuss mailing list
> >>>zones-discuss@opensolaris.org
> >>> 
> >>>
> >>>      
> >>>
> >>    
> >>
> 
> 
> 
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org
  • Re: [zones-di... David J. Orman
    • Re: [zon... Enda o'Connor - Sun Microsystems Ireland - Software Engineer
      • Re: ... David J. Orman
        • ... Enda o'Connor - Sun Microsystems Ireland - Software Engineer
          • ... David J. Orman

Reply via email to