Hi Robert,

The Solaris format command works at the drive level. You should not be able to format only a part of a drive, since that is all that you have been provided. You have provided all parts (via s*), possibly, but they are individual pieces, not the whole drive as one. The label is not in one of those pieces, at least not logically.


The zone isolation and abstraction of "shared" resources prevents you from minipulating those resources within a non-global zone. Otherwise, you could reconfigure a part of a resource provided to another zone.

Steffen

Robert Prus wrote On 05/11/06 12:13,:

Hi,

I recently tried to test this feature.

I passed access to e.g. /dev/*dsk/c0t0d0s* devices to non-global zone using zonecfg/device/match syntax.

Then, in non-global zone, I tried to use format(1M) to repartition this storage device but I was not able to perform this.

# format
Searching for disks...done


AVAILABLE DISK SELECTIONS:
       0. c1t1d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
          sd1 at pci1000,500 slave 8
Specify disk (enter its number): 0
selecting c1t1d0
[disk unformatted]


FORMAT MENU:
        disk       - select a disk
        type       - select (define) a disk type
        partition  - select (define) a partition table
        current    - describe the current disk
        format     - format and analyze the disk
        repair     - repair a defective sector
        label      - write label to the disk
        analyze    - surface analysis
        defect     - defect list management
        backup     - search for backup labels
        verify     - read and display labels
        save       - save new disk/partition definitions
        inquiry    - show vendor, product and revision
        volname    - set 8-character volume name
        !<cmd>     - execute <cmd>, then return
        quit
format> verify
Current Disk is unformatted.
format> label
Current Disk is unformatted.

(* END OF LISTING *)

Anyone knows why it is not working???

Greetings and thanks in advance,

Robert

_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to