Yes, the technique or reinstalling a new JDK in a local file system in the 
sparse zone (in my case I installed it in /usr/local/bin) where you have write 
permissions worked just fine.  The down side was that I already had a working 
JDK in both the global zone and the sparse zone.  I installed the 32-bit self 
extracting file and then the 64-bit self extracting file to get 64-bit support.

The /usr/local/bin was defined in the global zone as /usr/local_zsap24 and then 
mounted in the sparse zone as /usr/local.   I knew from some examples that I 
would need to do this.  The SAP installation proceeded uneventfully, though I 
am not done yet.  The JCE installation process was successful.
 
 
This message posted from opensolaris.org
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to