Hello, 

Truly Truly sorry ; now, at last ,this **REALLLY** the full text! I verified it 
with "preview" !
The thing is that some redirection to console in the text messed it somehow.So 
I omitted it.


 I tried to trace Zones booting with DTrace.

I ran DTrace thus: 
 dtrace -qn 'proc:::exec-success { printf("%-14s 
%s\n",curthread->t_procp->p_parent->p_user.u_comm, curpsinfo->pr_psargs); }'

and from another terminal ran:
  zoneadm -z myzone boot
what I got is:
tcsh           zoneadm -z myzone boot
zoneadm        zoneadmd -z myzone
zoneadmd       mount -o attrdir=/export/home/myzone/dev /dev 
/export/home/myzone/root/dev
zoneadmd       mount -o ro,nosub,nodevices /lib /export/home/myzone/root/lib
zoneadmd       mount -o ro,nosub,nodevices /platform 
/export/home/myzone/root/platform
zoneadmd       mount -o ro,nosub,nodevices /sbin /export/home/myzone/root/sbin
zoneadmd       mount -o ro,nosub,nodevices /usr /export/home/myzone/root/usr
zoneadmd       mount /opt/local /export/home/myzone/root/usr/local
zsched         /sbin/init
init           INITSH -c exec /lib/svc/bin/svc.startd   >/dev/msglog 
2<>/dev/msglog 
init           /lib/svc/bin/svc.startd
svc.startd     /lib/svc/bin/svc.configd
svc.startd     /sbin/sh -c exec /lib/svc/method/net-loopback

                
Now, I saw that in the "Solaris Internals" book there is the same dtrace script 
example for booting a zone. But with some differences.

In the book example, after the last mount, there is a call to 
"devfsadm -z demozone" while I do not have this at all.

My question is : as I understand, there is a single devfsadmd daemon
which runs on the global zone. Moreover , each zone was registered with this 
devfsadmd daemon by a door IPC; there was a door in /dev/.zone_reg_door  and 
also in /dev/.devfsadm_synch_door. I do not have these doors under /dev in 
"myzone".
        
My question is : was something changed in the zoneadmd and devfsadm 
doors interaction? I want to add that I am running snv_54; I did not 
find in the changelog anything about such a change, though.
         

(Another thing that I want to mention is that in the book example , 
root/dev is a mounted with zonedevfs option;
the first mount in the book is 
"zoneadmd       mount -o zonedevfs /zones/demozone/dev /zones/demozone/root/dev"
in my output it does not appear with the zonedevfs option.)

Regards,
Xu
 
 
This message posted from opensolaris.org
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to