I've run into the problem of a zone refusing to cleanly shut down a few
times now.  It gets stuck in the shutting_down state:

  6 as39             shutting_down  /zones/as39


Here's ps -efZ |grep as39 from the global zone:

   as39    root   584     1   0   Jun 24 ?           0:00 zsched
 global    root   575     1   0   Jun 24 ?           0:00 zoneadmd -z as39
   as39  svctag  4914  4890   0        - ?           0:00 <defunct>
   as39    root  4890     1   0   Jul 04 ?           1:25
/apps/oracle/oas/10.1.3.1/Apache/Apache/bin/httpd -d
/apps/oracle/oas/10.1.3.1/

I tried to kill -9 4914 and 4890 with no luck.  I tried to preap (w/ and w/o
-F) 4914 with no luck.  I've googled and I've seen this discussed in the
past but I want to know if there's any new suggestions.  I'm going to open a
call with Sun, what information should I gather for them?  halt -d?

This server is a T2000, S10 11/06:
SunOS gc16 5.10 Generic_118833-36 sun4v sparc SUNW,Sun-Fire-T200

This zone is a whole root zone and it lives on a zfs filesystem.

Thanks,

Steve
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to