Please take a look at this IBM Technote that solves a similar problem

and do the following steps.
1) Ensure that the file was edited to point to /opt/WebSphere/Profiles directory as described in the paper before you created the zones and profiles 2) In your dmgr profile's bin directory, the ** has two variables: "USER_INSTALL_ROOT" and "ITP_LOC". If you've done the previous step, USER_INSTALL_ROOT should point to your custom profile directory rather than $WAS_HOME/profiles/.... 3) Change ITP_LOC from *"$WAS_HOME"/deploytool/itp* to *"$USER_INSTALL_ROOT"/deploytool/itp
*4) Run

Please let me know how this solution works for you.


Redmar van Leeuwaarden wrote:

I have set up a new environment with Solaris 10 x86 Zones and WebSphere 6.1 
Network Deployment. The known whitepaper is used as baseline for the 

After implementing the whitepaper the three zones (dmgr, app1, app2) all run 
fine but then deploying a new application that uses EJBs errors occur...
The deployment manager is installed in a zone with a seperate profile located 
in /opt/WebSphere/Profiles/dmgr and uses the base from the global zone located 
in /opt/WebSphere/AppServer
The last step of installing an application containing EJBs results in errors 
from the itp deployment application that is used to deploy the EJB. The itp 
deployment tool that is started from the deployment manager tries to write 
files to its location in 
/opt/WebSphere/AppServer/deploytool/itp/configuration/, but this location is 
read only for the deployment manager (as it is inherited from the global zone).

A quick and dirty fix; linking 
/opt/WebSphere/AppServer/deploytool/itp/configuration/ (global) -> 
/opt/WebSphere/itp (local); proved that this is indeed is the problem when 
deploying EJBs.

Does any one have a more acceptable solution for this problem, or does any one 
now a way to configure the temporary workspace for the itp tool (not the 
osgi.instance.area.default variable, I really mean the temp files placed in the 
itp/configuration directory). I must imagine that more users have faced this 
This message posted from
zones-discuss mailing list

zones-discuss mailing list

Reply via email to