On Thu, Nov 15, 2007 at 11:02:17AM -0500, Pedro Espinoza wrote:
> I exported a file system sitting on a local zone
> (<zonepath>/root/VART/1> from the global zone to some servers in the
> subnet. When I tried to reboot the zone, I am getting the error for
> the said file system: mount of vxfs volume failed with exit code 16. I
> am thinking that the culprit is exporting a ngz file system from
> global zone. Have you run into these issues?  If so, how did you
> approach the problem?

i've never seen this problem since i've never used vxfs before.

> Like unsharing the export, before rebooting the
> zone?

that's what i'd recommend trying.  since you shared the filesystem
from the global zone, that added an extra reference count to it.
when a zone is shutdown, all filesystems are unmounted, and if they
fail to unmount gracefully they are force unmounted.  this would
still not remove a reference due to nfs exporting.  so this
is likely the cause of the problem your seeing.

zones-discuss mailing list

Reply via email to