On 9 jul 2008, at 21:42, Konstantin Gremliza wrote:

> I wrote a dtrace script to monitor zone states. The resulting  
> automata is in the attachment.
> In the state down, we should still have a zsched (ps), but we should  
> not have any mounted filesystems, which is true (df).
There is no zsched running in that zone and nothing is mounted either  
(apart from the zone root).

> Its quite correct that you cannot say
> zoneadm -z xxx boot
> when the zone is still down.
> Did you ever try
> zoneadm -z xxx halt
> ? If not, please do (this is my first tip).

I had tried that, and it hung.

Now that I tried the halt + boot again, it worked. I guess James  
suggestion might have been true, i.e. a stuck kernel thread.

This is not the first time it has happened, so when/if it happens  
again I'll know where to look.

> I see you have the root of the zone on zfs. I guess you know, that  
> this is not supported.
> Did you replicated the zones with zfs clone?

It is running on Nevada not Solaris 10, and as far as I know it is  
supported there :)

Thanks for your help and the zone automat picture.

Martin Englund, Security Engineer, .Sun Engineering, Sun Microsystems  
Email: [EMAIL PROTECTED] Time Zone: GMT-3 PGP: 1024D/AA514677
"The question is not if you are paranoid, it is if you are paranoid  

zones-discuss mailing list

Reply via email to