Steve Lawrence wrote:
> On Sun, Jul 13, 2008 at 09:22:07PM +0100, Matt Harrison wrote:
>> Steve Lawrence wrote:
>>> My guess is that your zones lack /var/ruby.*
>> Thanks for the reply,
>> My zones in fact do have /var/ruby* and I can list and view the files
>> which it tells me don't exist.
> Sometimes truss -f <command> <args> ... gives a good indication of exactly
> what file is not being found, assumming this is a missing file problem.
>>> Did you install ruby+friends in the global zone using packages, from
>>> a tar file, or from source compilation?  A package install from the global
>>> zone should install the package contents into all zones, properly handling
>>> /usr verses /var.
>> My ruby is installed from the OpenSolaris installer when the system was
>> built, the only thing I have manually installed was a handful of gems
>> which I did with the "gem" command.
> Which release of opensolaris are you using?  Are you sure /usr and /lib
> are read-only, as that is not the usual setup in the recent releases of
> opensolaris?

I'm running SCXE snv91 and the zone was created with very basic setup. 
/usr was definately read-only in the zone according to mount.

> Perhaps the gem command updates files in /var, which are per zone.  You may
> need to add the gems using the gem command in every zone.

Ok, I've done some digging and played with copying certain files. 
Basically /var is separate and doesn't contain my gems, so I tried 
copying my gems in, still not found.

Then I tried copying the source cache across too and that now works. 
Just for reference I rsync'd everything between /var/ruby/1.8/gem_home 
on the global and the local zones.

> It would be best to root cause your issue, rather than just attempt to work
> around it via another installation mechanism.  Please reply if adding the
> gems to each zone does not resolve the issue.

This is now sorted, just sync the contents of the above directories 
between the host and the zone. You could install the gems into the zone 
directly, but that would require a writable /usr as some of the gems 
install binaries or scripts there.

Thanks for the replies, you stimulated something in my mind so I went 
back to check things :)


zones-discuss mailing list

Reply via email to