Hi Jeff,

> > There are four single-threaded processes in the global zone, each of which 
> > could consume a whole core (the box has 4 dual-core cpus), but still the
> > global zone remains at ca. 50% cpu consumption.
> 
> Solaris sees this as an 8-CPU system. A single-threaded process can't

sorry, I should learn to count ;-)  The X4200 has *2* dual-core cpus, thus
4 cores.

> consume more than 1/8th of the system - 12.5%. So far, everything is
> as it should be. Running a fifth copy of that program should result in

The 4 instances of john should run at 25% each, one on each core.

> five processes, each at 12% - for a total of 60%.
> 
> > Starting additional processes has no effect either, even if they run as 
> > root.  I seem not to be
> > able to exceed the old zone.cpu-shares value of 50.
> 
> Are you saying that you have tried to run more than 4 copies of that
> program, and together they use about 50%? For example, if you run 6 of
> them, they each get 8%?

I ran two separate additional instances of yes > /dev/null as root, those
together got 25% cpu, and the 4 john instances another 25% (as verified
with prstat -J), but all 6 programs together didn't exceed 50%.

I've just running one instance of yes > /dev/null as root, which takes 23%
cpu according to prstat -J, and 4 john instances together take another 26%
(as expected according to project.cpu-shares, provided that root defaults
to 1 share if project.cpu-shares isn't set for user.root).

> Also, does "ps -ec" show that those 4 processes are in the FSS class?

Yes, I've just verified this.

        Rainer

-----------------------------------------------------------------------------
Rainer Orth, Faculty of Technology, Bielefeld University
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to