Starting from a sample file that Jerry had sent me, I did some more 
tests with various sysconfig file settings and found:


   (as per Jerry's sample) works

   works after I added the following to file 
/usr/lib/brand/ipkg/pkgcreatezone in the global zone (after line 179) 
before starting the installation of the zone:

# Get some locale and language packages:
pkglist="$pkglist SUNWloc SUNWlang-enUS"

I found out the packages by looking into /usr/share/locale and 
/usr/lib/locale and searching for locales using
"pkg search en_US.UTF-8", for example.

A package that contains several languages, for example, is: SUNWinstall-l10n


root_password=(long password string from 2008.11's /etc/shadow file)
   did not work for me (but maybe the correct password string would be 
only a substring of the second record in /etc/shadow - I haven't looked 
into the details).

root_password=(short password string from Solaris 10's /etc/shadow file)
   works fine. The old password string will be put into the new 
/etc/shadow file of the 2008.11 zone but can later be changed from the 
command line and will then be replaced by a long string.


   is apparently not needed, as the terminal and keyboard works fine for 
me even without that parameter.


   works fine. When using

   When the system cannot verify some of the information, it displays 
just one confirmation screen (as usual, after configuring the same 
settings by hand) and after choosing "No" to not enter the information 
again and using <esc>-2, the rest of the sysidcfg configuration remains 
intact and will not be asked again, and shortly afterwards the login 
prompt is displayed.


   did not work well with the configuration screen mentioned above 
(cursor was not displayed in the correct line) in gnome-terminal.

   (as per Jerry's sample) worked fine.



Jerry Jelinek wrote:
> Bernd Finger wrote:
>> Hi all,
>> I'd like to create a sysidcfg file to completely avoid configuration 
>> screens when booting a newly created zone.
>> I found that with OpenSolaris 2008.11, I have to mount a zone, create 
>> the /etc/sysidcfg file under the zone's root directory and then unmount 
>> the zone again before booting, 
> Yes, the zone's root is not mounted except when the zone is running.
> You can use 'zoneadm detach' on the zone which will leave the correct
> dataset mounted.  After you make any customizations in the filesystem,
> 'zoneadm attach' will reattach the zone and unmount the dataset.
>> but I am getting syntax errors when 
>> trying to configure a system locale or a keyboard entry using supported 
>> values as mentioned in 
>> http://docs.sun.com/app/docs/doc/819-5776/6n7r9js2j?a=view .
> I just tried a sysidcfg file on a new zone and the settings I used
> worked ok.  I'm not sure what settings you are using, so maybe there
> is something you are configuring that isn't installed yet.
>> What I also discovered is that after zone installation, the package that 
>> contains "/usr/bin/locale" (SUNWloc) is not installed in the zone. Could 
>> the problem be that one or more packages are missing after the zone 
>> installation? If yes - is there maybe an easy workaround?
>> I haven't tried yet to add packages in file 
>> /usr/lib/brand/ipkg/pkgcreatezone yet - any idea which other packages 
>> might be needed (e.g. for the keyboard keyword in /etc/sysconfig)?
> Jerry
> _______________________________________________
> zones-discuss mailing list
> zones-discuss@opensolaris.org
zones-discuss mailing list

Reply via email to