On Wed 03 Jun 2009 at 04:19AM, Chris Josephes wrote:
> I'm trying to build a zone on a fresh install of 2009.06 and I'm seeing the 
> exact same error.
> I'm using pkg.opensolaris.org/release as the authoritative repository,
> and it fails on the sanity check for the "entire" package.
> ERROR: Unable to locate the incorporation
> 'ent...@0.5.11,5.11-0.111:20090514T145840Z' in the preferred publisher
> 'opensolaris.org'.
> When I search the repository for 'entire' I see plenty of entries, but
> it doesn't list the full version numbers, so I can't tell if it's
> really listing the version that zoneadm expects to find.


Bah.  Sorry.  We (inadvertantly) created a situation where the
metadata in the repository is not really self-consistent with what's
on the CDROM, due to the novel way we published the final release bits.
Essentially, the global zone is trying to find a version of entire in
the repository which matches what it has.  But, there isn't one which
exactly matches.  So, the fix is to run:

$ pfexec pkg image-update

In your global zone (it should be reasonably quick because it will only
update the 'entire' meta-package).  Then reboot.  Then, all should work.
That worked for me in my test environment.  If not, please let me know.
And, my apologies :(

I'm also going to see if we can do some publication magic to get the
correct version of entire published into the repository, hopefully
in the next 48 hours.  This should correct the problem for most users.


Daniel Price, Solaris Kernel Engineering    http://blogs.sun.com/dp
zones-discuss mailing list

Reply via email to