hm.  detach is failing because attach never marked any zone dataset as
active.  could you file a bug against detach to make it more robust in
the face of failiures?

to work around this problem you might just want to edit /etc/zones/index
and change the zone state to "uninstalled".  (this will essentially undo
the "attach -F" you did earlier.)  then you can do an attach -u to
properly attach the zone.


On Fri, Jun 12, 2009 at 09:12:53AM -0700, Ian wrote:
> Hi Jerry,
> Ok - I fell through the cracks on the upgrade: nothing new there !
> I am having some trouble with the detaching though:
> # zoneadm -z web detach
> ERROR: Error: no active dataset.
> Do I have to mount/unmount web/ROOT/zbe manually before trying this ?  I 
> think I tried most combinations of zfs mount/unmount last night when I ran 
> into this, but haven't managed to solve it :(
> Thanks,
> --
> Ian.
> --
> This message posted from
> _______________________________________________
> zones-discuss mailing list
zones-discuss mailing list

Reply via email to