Are you running OpenSolaris 2009.06? A difference in this release is that each zone's root filesystem is unmounted when the zone is halted and then remounted when the zone is booted. If the unmount fails on halt, then the subsequent mount on boot fails because it's already mounted. The error message in this case matches what you're reporting.

To confirm that you are experiencing this problem (on 2009.06) try running this command in the global zone:

   # mount -p|grep ROOT

If you see entries like this:

   rpool/zones/public/ROOT/zbe - /zone/public/root zfs ...

and the zone name, e.g. public is not ready or running, the unmount apparently failed. You can probably do a forced unmount as a workaround, e.g.:

   # umount -f /zone/public/root

to clear the problem.


maco wrote:
Hiya all, hopefully you might be able to shed some light on a zones problem 
that I've got.  I think this is the correct forum to post to, as I've got 
OpenSolaris installed and working.  If not, please let me know and I'll repost 
to the correct forum!
I've got several zones installed and (until recently) all running correctly 
with no problems.  I've had to reboot the machine and since then, none of the 
zones are able to boot.  The only error message I'm getting is:

  r...@gaia:~# zoneadm -z poseidon boot
  zoneadm: zone 'poseidon': call to zoneadmd failed

I've tried restarting the zones:default service with svcadm, it starts 
correctly, shows as 'online' with svcs.  The log file is saying:

  [ Aug 12 21:24:59 Enabled. ]
  [ Aug 12 21:24:59 Executing start method ("/lib/svc/method/svc-zones start"). 
  Booting zones: poseidon apollo athena hades zeus
  zoneadm: zone 'hades': call to zoneadmd failed
  zoneadm: zone 'athena': call to zoneadmd failed
  zoneadm: zone 'poseidon': call to zoneadmd failed
  zoneadm: zone 'zeus': call to zoneadmd failed
  zoneadm: zone 'apollo': call to zoneadmd failed
  [ Aug 12 21:25:01 Method "start" exited with status 0. ]

I've tried google, but the errors others are getting are more specific (i.e. 
filesystem/vnic errors), but I can't see a simple solution.

I've only recently started using OpenSolaris, so I'm lacking in experience as 
to where to look now that the log files have been equally vague!  Any pointers 
to where to look for additional information, or an idea of what's gone wrong 
would be greatly appreciated.

Thanks for your time!

zones-discuss mailing list

Reply via email to