Thanks for the quick reply.  I installed OpenSolaris 2008.11, but have kept it 
up to date with the package manager.

The only mounted ROOT filsystem is the main one mounted on /.

I've since tried to make the zone ready with:

r...@gaia:/zones# zoneadm -z poseidon ready
zoneadm: zone 'poseidon': call to zoneadmd failed

I've also tried creating a new zone (test) to see if it's just existing zones 
that are affected, but the install command is failing:

r...@gaia:/zones# zoneadm -z test install
A ZFS file system has been created for this zone.
ERROR: Unable to create the zone's ZFS dataset.

which causes the test zone to show as incomplete:

r...@gaia:/zones# zoneadm list -icv
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              native   shared
   - poseidon         installed  /zones/poseidon                ipkg     excl
   - apollo           installed  /zones/apollo                  ipkg     excl
   - athena           installed  /zones/athena                  ipkg     excl
   - hades            installed  /zones/hades                   ipkg     excl
   - zeus             installed  /zones/zeus                    ipkg     excl
   - test             incomplete /zones/test                    ipkg     shared

Hopefully this might shed some light on the problem.
This message posted from
zones-discuss mailing list

Reply via email to