On Sun, Nov 22, 2009 at 11:52:24PM -0800, Daniel Dinu wrote:
> Hello,
>
> Yes - /zone1 is a separate filesystem.
>
> r...@server.com#zfs list
> NAME                       USED  AVAIL  REFER  MOUNTPOINT
> rpool                     12.7G   216G    81K  /rpool
> rpool/ROOT                5.30G   216G    19K  legacy
> rpool/ROOT/opensolaris    26.9M   216G  4.84G  /
> rpool/ROOT/opensolaris-1  5.27G   216G  4.96G  /
> rpool/dump                1.49G   216G  1.49G  -
> rpool/export              3.99G   216G    21K  /export
> rpool/export/home         3.99G   216G    21K  /export/home
> rpool/export/home/kido    3.99G   216G  3.99G  /export/home/kido
> rpool/newclone              17K   216G    20K  /newclone
> rpool/newfs                 20K  15.0G    20K  /newfs
> rpool/swap                1.49G   217G   101M  -
> rpool/zone1                474M   216G    21K  /zone1
> rpool/zone1/ROOT           474M   216G    19K  legacy
> rpool/zone1/ROOT/zbe        19K   216G    19K  legacy
> rpool/zone1/ROOT/zbe-1      19K   216G    19K  legacy
> rpool/zone1/ROOT/zbe-2     237M   216G   237M  legacy
> rpool/zone1/ROOT/zbe-3     237M   216G   237M  legacy
> r...@server.com:~# zfs list -t all -r rpool/zone1
> NAME                     USED  AVAIL  REFER  MOUNTPOINT
> rpool/zone1              474M   216G    21K  /zone1
> rpool/zone1/ROOT         474M   216G    19K  legacy
> rpool/zone1/ROOT/zbe      19K   216G    19K  legacy
> rpool/zone1/ROOT/zbe-1    19K   216G    19K  legacy
> rpool/zone1/ROOT/zbe-2   237M   216G   237M  legacy
> rpool/zone1/ROOT/zbe-3   237M   216G   237M  legacy
>
>
> I guess zbe-n were created during my several attempts to create the zone...
>

yep, a zbe filesystem is normally created during an install.  but
normally we detect that there is an existing filesystem for the zone so
we shouldn't be creating new ones.

we keep track of the zbe by using a uuid.  so could you display the
following zfs properties?

zfs get -r org.opensolaris.libbe:uuid rpool/ROOT
zfs get -r org.opensolaris.libbe:parentbe rpool/zone1/ROOT
zfs get -r org.opensolaris.libbe:active rpool/zone1/ROOT

> I noticed the mountpoint is set to "legacy" . Is this the way it should be?
>

the "legacy" mountpoint is correct.  the root of the zone will actually
be mounted when you try to boot the zone.  it would be interesting to
know if you are able to zoneadm(1m) "ready" the zone.  (booting is
really two steps, and implicit "ready" and then a "boot".)

ed
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to