Jerry Jelinek wrote:
Robert Hartzell wrote:
I have upgraded 3 systems from 127 to 128a and all the zones basically have the same error. autofs is in maintenance with 17 dependent services not running. I haven't upgraded the zones because they are in production and don't want to have to recreate all 7 of them again. Is this a known issue or am I just the lucky one? I do have one system that I can trouble shoot on if anyone has some ideas.

By not upgrading the zones you've put the system into an
unknown and unsupported state.  The zones must be running
the same system software as the global zone.  You can
use the following sequence of commands to update the zones
so that they are in sync with the global zone:

# zoneadm -z foo detach
# zoneadm -z foo attach -u
# zoneadm -z foo attach

The second attach is needed to work around a bug in b128.
Normally this is not needed.

Eventually the image-update code will automatically keep
the zones in sync with the global zone but that code is
still being designed.  In the meantime you have to manually
keep the zones in sync as shown above.


My normal procedure is to image-update, reboot, check that everything is working then update each zone. This has always worked because the zones would still be running. All my external services are running in zones (dns, smtp, http, ftp) so when I reboot I have no dns and therefore can't update the zones. Not much I can do about the single point of failure so is there a way I can update the zone before I reboot?

  Robert W Hartzell
bear at
zones-discuss mailing list

Reply via email to