If I create the following file
-a modify
-n myzonename
-m "comment:new comment"

and I run zonemgr -f file
only the first part of the comment is taken into account and applied to the 
zone.
This comes from the logic used when reading the configuration file in 
load_cfg_file() and relaunching the command line with
${0} `cat ${zCfgFile} | sed -e "s/^/ /g" -e "s/\"//g" | tr -d "\n"`

Removing the -e "s/\"//g" doesn't help, because single quotes are reintroduced 
and split our comment.
To summarize, spaces in comments are unsupported, whether in zone creation or 
modification, when the configuration is read from a file.

I've tried to use "eval" in the command above in load_cfg_file(), but then the 
pipes used in certain options are garbled.
Using "xargs" disables usage of standard input for the yes/no questions ...

So, no real solution, except perhaps substituting spaces by underscores in the 
input file and performing a "sed" afterwards, but that's really bad ...

Using command-line parameters works well.
-- 
This message posted from opensolaris.org
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to