Hello

2010/6/30 Matthias Pfützner <matth...@pfuetzner.de>

> I assume, it has something to do with the below error messages regarding
> the
> rpool. But, sadly, I'm not sure...
>
> Ok.


> Which is OK, but for learning purposes might be a bit to lightwight... A
> two-node cluster is better...
>
> Ok. But what I really want to do is something which can be done using
single node cluster only.So I can just now do that with single node cluster
and then try two-node cluster.


> No, that's OK!
>
> Ok.


>
> > No actually i just created two zfs filesystems on rpool as I have told
> > earlier.
> > Is it wrong ?
>
> I assume so, yes... As the thing, that can be moved are the POOLS, not the
> zfs
> Filesystems. Therefore, you would have needed a new pool, which can be
> moved
> from system to system... you can't MOVE the rpool, as that's needed for the
> basic underlying OS... ;-)
>
> Ok. Actually I could not get much after reading about pools so I tried the
shortcut way.
Ok. I will try doing something else for it. Also one more thing I will tell
you is that I have not created a separate "/globaldevices" as it was written
in the manual.
so scinstall asked me to use lofi device (I don't know what it means) and I
accepted that option. Could it be a problem ?


> > I think I can reinstall opensolaris only and install OHAC on it again but
> I
> > have reinstalled this for the second time only. :(
>
> I guess, you would NOT need to re-install, but to just DECONFIGURE all the
> resources, storage et.al. that you did in the cluster config.
>
> Ok. I will do that once I figure out everything correctly because I don't
want to commit this mistake again. :(


> > Actually in the manual it was suggested to create a mirror zpool of the
> root
> > filesystem and then install zfs on it or create a pool on file but I
> thought
> > I could use the original rpool only.
>
> For testing, you don't need the mirror.
> Yes, as stated above, the "thing" that will be "failed-over" is the
> POOL. Therefore you need a pool. And you simply can't use the rpool...
>
> Ok. Could you suggest me how do I do that ? Or I will be consult manual
again
zpool create -m mountpoint pool mirror /dev/rdsk/cNtXdY \
/dev/rdsk/cNtXdZ

this is the command given in the manual could you suggest me what shoud I
give in place of cNtXdY
and I have virtual hard disk named c7d0


> > Is this the reason for all problems ?
>
> It might be!
>
> > But as far as I remember display is not working since I ran scinstall and
> I
> > did this all zone work from the console only so I don't think this could
> be
> > the reason.
>
> That's the strange thing... But, in order to be sure, when that really
> started, I would propose to really de-configure the actual cluster setup,
> and
> staring all over again (not with INSTALL, only with configuring!)
>
> Yes that's the most confusing thing. Ok I try doing that only now.

Thank you very much for your help. :)


> > --
> > Thanks and Regards ,
> > Gaurav Saxena
>
>   Matthias
> --
>    Matthias Pfützner    | mailto:pfu...@germany | Am Anfang wäre das Stück
>  @work: +49 6103 752-394 | @home: +49 6151 75717 | schnell zu Ende.
>  SunCS, Ampčrestraße 6  | Lichtenbergstraße 73  | (21.10.93)
>    63225 Langen, FRG    | 64289 Darmstadt, FRG  | Hellmuth Karasek
>



-- 
Thanks and Regards ,
Gaurav Saxena
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to