On 07/27/10 03:03 PM, Edward Pilatowicz wrote:
On Tue, Jul 27, 2010 at 02:17:45PM -0700, Sunay Tripathi wrote:
On 07/27/10 01:06 PM, Edward Pilatowicz wrote:
On Mon, Jul 26, 2010 at 10:54:24PM -0700, Sunay Tripathi wrote:

I think we had discussed allowing a ipkg brand zone to be installed
without a network i.e. going to a repo if I already have a installed

offline zone install is not available today.  there is a bug for this
and we will have it someday:

1947 Offline zone creation is impossible

Ah. Although it seems like its labeled an RFE but this is a
regression from earlier native zones where one could create
zone on his laptop while sitting on a beach. Now I am just
a developer but for most large data center managers, each
machine needing to go to a repo to create a zone is going
to put them in a very bad mood ;^) I would suggest upping
the priority on that ...

hm.  if i was a data center manager (or developer) sitting on a beach, i
don't think i'd be thinking about zone installs.  i'd probably also be
in a pretty good mood, assuming the weather was nice.  but yes, this is
arguably a regression from s10 zone install.

Hey.. pacific is too cold to go in water anyway. So a day on beach is
more fun with a laptop although getting AT&T to give to good wifi
connectivity is a bigger stretch :) Thats where zones come in handy
with some of the newer nehlam based laptops. Seriously, lot of
value in zones and crossbow was doing things like Vwire which
allowed you to test network based apps without needing a network.
Now if I need a network just to create a Vwire, thats a dampener.

system running. Can someone tell the correct options? I am trying
the -d option but that fails ...
# zoneadm -z test install -d /
pkg list: no packages matching 'entire' installed
you must specify -u (sys-unconfig) or -p (preserve identity).
brand-specific usage:
         install {-a archive|-d path} {-p|-u} [-s|-v]

since you don't have entire installed it's not possible to install valid
zones (even if you have an accessible repo).  there is a bug on this:

16568 zoneadm install can create out of sync zones if entire has been removed

OK. If you address this at least, its a good start.

i'd recommend that you install zones before running onu.

The attach -u after onu still fails although I haven't tried
to debug that.

attach -u should succeed as of snv_132.  (with the fix for 12738.)  of
course you still need to have access to the repo that onu used when
updating your gz.

Hmm. I tried that a few times and moved on to recreating the zones.
Its possible that there was something else screwed up. I will try
it again one of these days.

i'd also strongly recommend running recent builds.  if your running
older builds then lots of stuff will be broken.

Thats what got me here in the first place :)

well, in another email you mentioned you were using external repos.  so
even if you've onu'd to more recent bits, you don't have the most recent
ips consolidation bits, which is where the fix for 12738 is.  i don't
remember what the most recently available external build is, but if you
started with something older than snv_132 then you might want to
consider building and installing more recent ips bits (in addition to ON
bits) if you want to use zones.

Ah yes. You are right about me not having the most recent pkg bits. BTW,
probably more of a question for pkg-discuss - why is pkg bits not
integrated in ON already? I would personally love to see all caiman
stuff also come in ON at as it gets done. Will get more people looking
and playing with it => better quality.


zones-discuss mailing list

Reply via email to