On 11/19/10 08:26 AM, John D Groenveld wrote:
In message<4ce57afe.9070...@ianshome.com>, Ian Collins writes:
I run through the upgrade process on a system with half a dozen zones
and on restart, they all get locked into a core dump/restart loop:

Nov 19 07:57:50 i7 genunix: [ID 729207 kern.warning] WARNING: init(1M)
for zone webhost (pid 3094) core dumped on signal 12: restarting

They all run through this cycle in tight loops.
I saw this on one Express upgrade.

I usually halt, detach, image-update, and attach -u, but on my failed
update I neglected to detach the zone. Whoops.

I halted the zone, detached, and after some failed attempts to attach
with zoneadm discovered that there was ZFS clone of the zone's zbe.

I performed a zfs send -R of the source snapshot, destroyed the
source ZFS and the dependant clone, and restored the original zbe.

I was able to get the attach -u to subsequently worked.

Also, I sacrificed a chicken but not sure whether that helped.

Well that's me buggered, I don't have any on hand!

I'm guessing this is a manifestation of the issue "Zones Cloned by Using zoneadm clone Can Cause a Snapshot Name Collision When You Activate a Boot Environment (10990)" mentioned in the release notes.

I had assumed I wouldn't have this problem because I wasn't upgrading from 2009.06 and I haven't (consciously) used zoneadm clone.


zones-discuss mailing list

Reply via email to