Thank you sir.  I had forgotten, overlooked, or other wise failed to try doing 
a -F to force the attachment.  I tried that and it shows as installed, then was 
able to boot it.

Before that I got these errors:

zoneadm -z myzone attach
These packages installed on this system were not installed on the source system:
        SUNWebrg (1.1.0,REV=2006.
        SUNWeupdatemgru (0.1,REV=2005.
        SUNWezfsg (1.0,REV=2006.
        SUNWfbrg (1.1.0,REV=2006.
        SUNWfupdatemgru (0.1,REV=2005.
        SUNWfzfsg (1.0,REV=2006.
        SUNWj5dev (1.5.0,REV=2004.
        SUNWjato (2.1.2,REV=2005.
        SUNWjhdev (2.0,REV=2006.10.04)
        SUNWmcon (3.0.2,REV=2006.
        SUNWmconr (3.0.2,REV=2006.
        SUNWmcos (3.0.2,REV=2006.
        SUNWmcosx (3.0.2,REV=2006.
        SUNWmctag (3.0.2,REV=2006.
        SUNWtcatu (11.10.0,REV=2005.
        SUNWzfsgr (1.0,REV=2006.
        SUNWzfsgu (1.0,REV=2006.
These patches installed on this system were not installed on the source system:
[solcon3/root] zoneadm -z myzone boot

zoneadm: zone 'myzone': must be installed before boot.

I don't understand the missing / not installed on source errors as these two 
servers were created from the same image so there should not be any differences.

I will see what happens with the third server.

Matthew Taylor
Systems Engineer
Montgomery College
Office of Information Technology
15400 Calhoun Drive, Suite 310
Rockville, MD 20855
240.567.3100 (Office)
410.868.8336 (Cell)
240.567.3008 (Fax)

On Dec 7, 2010, at 11:33 PM, Ian Collins wrote:

>  On 12/ 8/10 05:03 PM, Taylor, Matthew wrote:
>> I have three V245 servers with identical architecture, running latest 
>> Solaris 10.
>> I have configured a whole root zone using shared IP on one of the servers.  
>> I was able to easily clone a second copy of the zone on the first server.  I 
>> have everything in the zone the way I want it, locked down, user accounts 
>> created, correct patches and packages, etc.
>> Is it possible to copy this working (but halted) zone from one server to a 
>> second server?  I do not want to move / migrate it to a new server, I want 
>> to put a working copy over, change the zone name and host name, etc., and 
>> fire it up so I don't have to do all the work for each server.
>> I have read and followed the Oracle white paper "How to Move an Oracle® 
>> Solaris Container" with no success.  Unfortunately the examples in the paper 
>> are for sparse zones.
>> The problem I hit is I can get the date copied over, and run zonefg with no 
>> problem, but when I try to attach the zone, let alone when I tried to boot 
>> it (just in case it "just worked") I get a zone not installed error.
> What is the exact output when you attempt to attach the zone?   Can you 
> force (-F) the attach?
> I've copied zones between systems several times without errors.
> -- 
> Ian.

zones-discuss mailing list

Reply via email to