2010/12/22 gerard henry <solar...@gmail.com>

> i tried another approach like this:
> m...@src:~$ pfexec zfs send -R  rpool/zones/w...@move | ssh dst pfexec "zfs
> receive -d rpool"
> cannot receive: local origin for clone rpool/zones/www2/ROOT/zb...@zbe-2does 
> not exist
>
>
> on the source server:
> m...@src:~$ zfs destroy rpool/zones/www2/ROOT/zb...@zbe-2
> cannot destroy 'rpool/zones/www2/ROOT/zb...@zbe-2': snapshot has dependent
> clones
> use '-R' to destroy the following datasets:
> rpool/zones/www2/ROOT/z...@20100709
> rpool/zones/www2/ROOT/z...@electre
> rpool/zones/www2/ROOT/zbe
>
> m...@src:~# zfs list -r rpool/zones/www2
> NAME                            USED  AVAIL  REFER  MOUNTPOINT
> rpool/zones/www2             2.46G  11.9G    37K  /zones/www2
> rpool/zones/www2/ROOT        2.46G  11.9G    18K  legacy
> rpool/zones/www2/ROOT/zbe    1.81M  11.9G  1.76G  legacy
> rpool/zones/www2/ROOT/zbe-2  2.45G  11.9G  1.03G  legacy
> m...@src:~# zoneadm -z www2 halt
> m...@src:~# zoneadm -z www2 detach
> m...@src:~# zfs list -r rpool/zones/www2
> NAME                            USED  AVAIL  REFER  MOUNTPOINT
> rpool/zones/www2             2.46G  11.9G    37K  /zones/www2
> rpool/zones/www2/ROOT        2.46G  11.9G    18K  legacy
> rpool/zones/www2/ROOT/zbe    1.81M  11.9G  1.76G  legacy
> rpool/zones/www2/ROOT/zbe-2  2.45G  11.9G  1.03G  /zones/www2/root
>
> Can i safely destroyed the datasets above, if i understand well, my zone is
> only using:
> rpool/zones/www2/ROOT/zbe-2
>
> thanks for help,
>
>
> 2010/12/22 John D Groenveld <jdg...@elvis.arl.psu.edu>
>
> In message 
> <aanlkti=by3uj7pz_qns17s-py37=e_cpkvjqrzuei...@mail.gmail.com<e_cpkvjqrzuei%2...@mail.gmail.com>>,
>> gera
>> rd henry writes:
>> >i have a sun x4150 with 4 zones (b111). I want to upgrade to b134, before
>> >upgrading to S11express.
>> >The process fails. As a workourand, i'm trying to move zones on another
>> >server in b134. So i'm tryng to follow the official document found here:
>> >http://docs.sun.com/app/docs/doc/819-2450
>> >page 307.
>> >It also fails when trying to attach a zone on the destination server:
>> >zoneadm -z www2 attach -u
>> >Log File: /var/tmp/www2.attach_log.oJaO4J
>> >ERROR: no active dataset.
>>
>> What is the output of zfs list and mount for the filesystems
>> associated with these zones?
>>
>> John
>> groenv...@acm.org
>>
>> _______________________________________________
>> zones-discuss mailing list
>> zones-discuss@opensolaris.org
>>
>
>
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to