Benjamin Reed updated ZOOKEEPER-5:

    Status: Open  (was: Patch Available)

-1 SnapshotUpgradeV1 should be UpgradeSnapshotV1 since it implements 
SnapshotUpgrade. createThisSnapshot should be renamed since it doesn't create a 
snapshot. loadOldDataTree maybe? PersistentStat is going to be changing, so 
convertDataNode will need to be able to take the old version. Finally, you need 
test cases.

> Upgrade Feature in Zookeeper server.
> ------------------------------------
>                 Key: ZOOKEEPER-5
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-5
>             Project: Zookeeper
>          Issue Type: New Feature
>          Components: server
>            Reporter: Mahadev konar
>            Assignee: Mahadev konar
>             Fix For: 3.0.0
>         Attachments: ZOOKEEPER-5.patch, ZOOKEEPER-5.patch, ZOOKEEPER-5.patch
> We need an upgrade feature in zookeeper where we can upgrade the old 
> databases to a new one.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to