Mahadev konar commented on ZOOKEEPER-383:

the patch looks good flavio. I have some comments and questions -

- I think this is old code - it seems like all the callbacks (other than 
create/open) return a ledger id. Do we need that?
  In case someone needs to use the ledgerhandle or id in the callback he should 
be able to pass that via
  the Object ctx, no? The more useful case would be that we get the 
ledgerhandle in the return callback, but I think
  the application can do it better passing it via Object ctx.

-  ledgermanagementprocessor has some unused imports and unused variables

-  one other thing, you might want to consider breaking the run method into 
different methods for readability and maintainence.
   Its a huge method currently.

> Asynchronous version of createLedger()
> --------------------------------------
>                 Key: ZOOKEEPER-383
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-383
>             Project: Zookeeper
>          Issue Type: New Feature
>          Components: contrib-bookkeeper
>            Reporter: Utkarsh Srivastava
>            Assignee: Flavio Paiva Junqueira
>         Attachments: ZOOKEEPER-383.patch, ZOOKEEPER-383.patch, 
> ZOOKEEPER-383.patch
> While there are async versions for read and write, there is no async version 
> for creating a ledger. This can cause applications to have to change their 
> whole thread design. 
> It should be easier and more consistent to add an async version of 
> createLedger().

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to