Patrick Hunt commented on ZOOKEEPER-532:

The main reason is that we don't ship code that causes our own tests to fail. 
We try to the best of our
ability to guarantee that our code is as reliable and as highly available as 

We state in the release docs that only 1.6 is officially supported:

> java compiler should be target Java 1.5
> ---------------------------------------
>                 Key: ZOOKEEPER-532
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-532
>             Project: Zookeeper
>          Issue Type: Bug
>    Affects Versions: 3.2.1
>            Reporter: Hiram Chirino
>            Assignee: Hiram Chirino
>             Fix For: 3.3.0
>         Attachments: ZOOKEEPER-532.patch
> The jars released in 3.2.1 will not run on Java 1.5.  With a small build 
> change, it is possible to generate jars that will run on Java 1.5.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to