zkCli.sh  generates a ArrayIndexOutOfBoundsException 

                 Key: ZOOKEEPER-780
                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-780
             Project: Zookeeper
          Issue Type: Bug
          Components: scripts
    Affects Versions: 3.3.1
         Environment: Linux Ubuntu running in VMPlayer on top of Windows XP
            Reporter: Miguel Correia
            Priority: Minor

I'm starting to play with Zookeeper so I'm still running it in standalone mode. 
This is not a big issue, but here it goes for the records. 

I've run zkCli.sh to run some commands in the server. I created a znode 
/groups. When I tried to create a znode client_1 inside /groups, I forgot to 
include the data: an exception was generated and zkCli-sh crashed, instead of 
just showing an error. I tried a few variations and it seems like the problem 
is not including the data.

A copy of the screen:

[zk: localhost:2181(CONNECTED) 3] create /groups firstgroup
Created /groups
[zk: localhost:2181(CONNECTED) 4] create -e /groups/client_1
Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: 3
        at org.apache.zookeeper.ZooKeeperMain.processCmd(ZooKeeperMain.java:581)
        at org.apache.zookeeper.ZooKeeperMain.run(ZooKeeperMain.java:311)
        at org.apache.zookeeper.ZooKeeperMain.main(ZooKeeperMain.java:270)

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to