Allow non-numeric version strings

                 Key: ZOOKEEPER-891
             Project: Zookeeper
          Issue Type: Improvement
          Components: build
            Reporter: Eli Collins
            Priority: Minor
             Fix For: 3.4.0, 4.0.0

Non-numeric version strings (eg -dev) or -are not currently accepted, you 
either get an error (Invalid version number format, must be "x.y.z") or if you 
pass x.y.z-dev or x.y.z+1 you'll get a NumberFormatException.  Would be useful 
to allow non-numeric versions. 

     [java] All version-related parameters must be valid integers!
     [java] Exception in thread "main" java.lang.NumberFormatException: For 
input string: "3-dev"
     [java]     at 
     [java]     at java.lang.Integer.parseInt(
     [java]     at java.lang.Integer.parseInt(
     [java]     at 
     [java] Java Result: 1

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to