Patrick Hunt commented on ZOOKEEPER-908:

Thanks Thomas. As we are refactoring this code anyway, and our raised 
consciousness on "best practices", how about implementing some tests for the 
effected class (packet?). Any low hanging fruit that you see (perhaps a bit 
more refactoring may be needed) wrt test coverage?

If you think it's ready, or if after you add tests, click on the "submit patch" 
link to transition this to patch available (at which point we'll review for 
commit, and typically (if it wasn't currently broken) the automated patch tests 
would run.)

> Remove code duplication and inconsistent naming in ClientCnxn.Packet creation
> -----------------------------------------------------------------------------
>                 Key: ZOOKEEPER-908
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-908
>             Project: Zookeeper
>          Issue Type: Sub-task
>          Components: server
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>            Priority: Minor
>             Fix For: 3.4.0
>         Attachments: ZOOKEEPER-908.patch
> rename record -> request (since their is a counterpart record named 
> "response")
> rename header -> requestHeader (to distinguish from responseHeader)
> remove ByteBuffer creation code from primeConnection() method and use the 
> duplicate code in the Packet constructor. Therefor the Bytebuffer bb 
> parameter could also be removed from the constructor's parameters.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to