Patrick Hunt commented on ZOOKEEPER-805:

Hi Mahadev, I don't think that's necessary given you can fallback to 
"traditional" nc, or you can use the -q option as suggested by akovi.

On my ubuntu system (lucid/maverick) I have two executables; nc.openbsd and 
nc.traditional. "nc" links to openbsd version by default.

Honestly I'm not sure why this is no longer working, given that we addressed 
the "nc closes input first" in ZOOKEEPER-737

> four letter words fail with latest ubuntu nc.openbsd
> ----------------------------------------------------
>                 Key: ZOOKEEPER-805
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-805
>             Project: Zookeeper
>          Issue Type: Bug
>          Components: documentation, server
>    Affects Versions: 3.3.1, 3.4.0
>            Reporter: Patrick Hunt
>            Priority: Critical
>             Fix For: 3.3.2, 3.4.0
> In both 3.3 branch and trunk "echo stat|nc localhost 2181" fails against the 
> ZK server on Ubuntu Lucid Lynx.
> I noticed this after upgrading to lucid lynx - which is now shipping openbsd 
> nc as the default:
> OpenBSD netcat (Debian patchlevel 1.89-3ubuntu2)
> vs nc traditional
> [v1.10-38]
> which works fine. Not sure if this is a bug in us or nc.openbsd, but it's 
> currently not working for me. Ugh.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to