Usually this indicates that either a firewall is blocking one or more of the ports, or the server isn't started on all the hosts. First verify connectivity, I usually use telnet, see detail here:


Mark Vigeant wrote:
Ok, so now the clientPort is all set, but I'm running into another problem.

When I try to start up zookeeper server, the error I'm getting now is that it 
can't open the channel to the other machine:

2009-10-223 10:39:11,941 - WARN 
[QuorumPeer:/0:0:0:0:0:0:0:0:2181:quorumcnxmana...@336] - Cannot open channel 
to 2 at
election address leela/ Connection refused

I've checked to see if ports 2888 or 3888 are in use on either machine and they are not. Also, there is an open ssh between the 2 of them. I've tried on a few other ports as well and it's giving me the same issue. Do I need to tamper with port permissions?
-----Original Message-----
From: Patrick Hunt [] Sent: Friday, October 23, 2009 1:23 AM
To:; Mark Vigeant
Subject: Re: Cluster Configuration Issues

That usually indicates that you have a process that's already using a port that you've specified zookeeper to use. Try something like:

netstat -a -n -p tcp

and look at 2181/2888/3888 on the hosts you are using. Either use a different port or stop the process that's currently using.


Mark Vigeant wrote:
Haha well I'm an idiot. Thank you.

I would end there but a new error is being thrown:

2009-10-22 18:00:17,178 - FATAL [main:quorumpeerm...@86] - Unexpected 
exception, exiting abnormally Address already in use

-----Original Message-----
From: Henry Robinson [] Sent: Thursday, October 22, 2009 6:01 PM
Subject: Re: Cluster Configuration Issues

yeah - thought this was it: you've missed the forward slash on
home/mark/zookeeper (this turned up on your exception message).

On Thu, Oct 22, 2009 at 2:55 PM, Mark Vigeant

Yeah I just figured out the problem with

I am running as the same user who created myid. Here's my config:


server.1= hermes:2888:3888
server.2= leela:2888:3888

on the machines hermes and leela I've put myid files in
with the numbers 1 and 2 respectively
-----Original Message-----
From: Henry Robinson []
Sent: Thursday, October 22, 2009 5:43 PM
Subject: Re: Cluster Configuration Issues

Hi Mark -

The Python error relates to not being able to find the zoocfg module - is in the same directory as

Another couple of questions - are you running zookeeper as the same user
created myid? Can you post your entire configuration file please - copy and


On Thu, Oct 22, 2009 at 2:32 PM, Mark Vigeant

Before I make the Jira, I am trying to go with Ted's advice to use the
python script.

Unfortunately I'm relatively unfamiliar with python so I'm having trouble
running it.

When I execute "Python" on the command line it tells me:
Traceback (most recent call last):
  File "", line 27, in <module>
       from zoocfg import zoocfg
ImportError: No module named zoocfg

The same error comes when I try to call from the python
and when I try running
Python -help /home/hadoop/zookeeper-3.2.1/ /home/hadoop (as I
gathered from the Usage). Any suggestions?

Also, I've been using zookeeper 3.2.1
-----Original Message-----
From: Ted Dunning []
Sent: Thursday, October 22, 2009 4:33 PM
Subject: Re: Cluster Configuration Issues

Try Patrick's utility for creating the config files and compare the
to your hand-made files.

On Thu, Oct 22, 2009 at 1:04 PM, Mark Vigeant

The file contains the number 1 and nothing else. My other node has the
number 2 (I only have 2 machines right now, I know it makes more sense
run an odd number of zookeeper nodes but I just want to make sure it
first). Any suggestions?

Ted Dunning, CTO

Reply via email to