Five 1.0 released!

The Five team is happy to release Five 1.0. Five is a Zope 2 product
that allows you to integrate Zope 3 technologies into Zope 2, today.

There are no big feature additions compared to Five 0.3, but does
include significant bugfixes, along with some minor tweaks. We went
directly to 1.0 as we feel that Five is production-ready

Five 1.0 works with Zope 2.7. The big news is that we also plan to
include Five 1.0 in Zope 2.8, so that you can use Zope 3 technology in
Zope 2.8 out of the box. Much work to enable this was done at the
Paris Zope 3/Five sprint organized by Nuxeo. This release therefore
also contains the changes made to integrate Five into Zope 2.8 done at
the Paris Zope 3/Five sprint, but works with Zope 2.7.

Consult the CHANGES_ for more details.


Five right now allows you to use the following Zope 3 technologies in
Zope 2:

* Zope 3 interfaces

* adapters

* pages (views), including skins, layers and resources

* edit and add forms, based on schemas


We've tried to keep the Five experience as close to Zope 3 as
possible, so this means that what you learn while using Five should
also be applicable to Zope 3.

Five 1.0 is being used in production-grade projects, among others at
Nuxeo_ and Infrae_.

.. _Nuxeo:

.. _Infrae:

Five 1.0 can be downloaded here:

More information about Five can be found on our website, here:

We hope you'll join our mailing list and let hear from yourself!

About the Zope 3 Base

Five is part of the *Zope 3 Base* project, which aims to offer an
approachable area for developers of Zope 3 related software. More
about the Zope 3 base and its projects can be found here:
Zope-Announce maillist  -

 Zope-Announce for Announcements only - no discussions

(Related lists - Users:
Developers: )

Reply via email to