Hi there!

While testing CMF 1.5.1 with the new Zope 2.8 I stumbled upon a
problem with the creation of new objects. 

In its "_queryFactoryMethod"-method the TypesTool calls validate the
following way:

  getSecurityManager().validate(p, p, self.factory, m)

while the signature of validate (taken from
lib/python/AccessControl/ImplPython.py) is

  def validate(self, accessed, container, name, value, ...)

As after installing the new software the usual list of addable content
types turned up empty, I tried patching _queryFactoryMethod to use

  getSecurityManager().validate(p, container, self.factory, m)

instead, after checking that container indeed pointed to the object I
tried adding content to.

Now, this is strictly a "works for me"-solution, I don't know if it
breaks anything else or if it was only needed, since my CMF-instances
have been constantly upgraded since CMF 1.1.

Can anyone here shed some more light on this issue?


internetmanufaktur jo----------------------------- Berlin, Germany
  |||||||||||||||meder-------------------fon: ++49-30-417 17 63 33
http://www.meder.de/ ------------------- fax: ++49-30-417 17 63 45
Kollwitzstr. 75 ------------------------ mob: ++49-170- 2 98 89 97
10435 Berlin ---------------http://www.meder.de/keys/jo-pubkey.txt
Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to