Does anybody else get one failure and one error from the unit tests
on a fresh install of CMF 1.4.8?
Will there be a 1.4.9? If so, these prob'ly oughta be looked at...
I searched the collector and didn't find anything related to these tests.
I'm using Zope 2.7.7, Python 2.3.5 on linux.

[EMAIL PROTECTED] PaulInst2]$ ls Products/
CMFActionIcons  CMFCalendar  CMFCore  CMFDefault  CMFTopic  DCWorkflow
[EMAIL PROTECTED] PaulInst2]$ ./bin/zopectl test
Running tests via: /usr/local/bin/python
/zope/Zope-2.7.7-SoftwareHome/bin/test.
py -v --config-file /zope/PaulInst2/etc/zope.conf --libdir Products
Running unit tests at level 1
Running unit tests from /zope/PaulInst2/Products
Parsing /zope/PaulInst2/etc/zope.conf
.................................................................................
.................................................................................
.................................................................................
...........................................E...F.................................
.................................................................................
.................................................................................
.................................................................................
.................................................................................
.................................................................................
.............................................................
======================================================================
ERROR: test_invokeFactory
(Products.CMFCore.tests.test_PortalFolder.PortalFolder
FactoryTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/zope/PaulInst2/Products/CMFCore/tests/test_PortalFolder.py", line
78, i
n test_invokeFactory
    f.invokeFactory( type_name='Dummy Content', id='foo' )
  File "/zope/PaulInst2/Products/CMFCore/PortalFolder.py", line 367, in
invokeFa
ctory
    pt.constructContent(type_name, self, id, RESPONSE, *args, **kw)
  File "/zope/PaulInst2/Products/CMFCore/TypesTool.py", line 709, in
constructCo
ntent
    ob = info.constructInstance(container, id, *args, **kw)
  File "/zope/PaulInst2/Products/CMFCore/TypesTool.py", line 388, in
constructIn
stance
    m = self._getFactoryMethod(container)
  File "/zope/PaulInst2/Products/CMFCore/TypesTool.py", line 334, in
_getFactory
Method
    raise ValueError, ('Product factory for %s was undefined' %
ValueError: Product factory for  was undefined

======================================================================
FAIL: test_contentPaste
(Products.CMFCore.tests.test_PortalFolder.PortalFolderTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/zope/PaulInst2/Products/CMFCore/tests/test_PortalFolder.py", line
370,
in test_contentPaste
    assert 'dummy' in sub1.contentIds()
AssertionError

----------------------------------------------------------------------
Ran 780 tests in 105.809s

FAILED (failures=1, errors=1)

-- 
Paul Winkler
http://www.slinkp.com



_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to