Yesterday I fixed mailPassword and registeredNotify on the trunk. Since 'registered_notify_template' and 'mail_password_template' now might contain unicode translations all values passed to them have to be decoded and the rendered return value has to be encoded. I decided to wrap the templates in scripts for this.

'registered_notify_template' and 'mail_password_template' are no good names for scripts, '_template' is always used for page templates. So I decided to call more neutral method names from mailPassword and registeredNotify.

'mail_password' is already used, so I choose completely new names: 'member_password_mail' and 'member_registered_mail'.

Now my questions:

1.) If used with Localizer or PTS the old templates should still work. Do we have to provide backwards compatibility for the old template names? In a plain CMF environment backwards compatibility isn't possible anyway.

2.) I'm not sure about the new names. Meanwhile I tend to use shorter names: 'password_email' and 'registered_email'. The names for the related templates are too long right now. Any preferences?

If nobody cares I'll use 'password_email' and 'registered_email' and provide no backwards compatibility.



Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to