Hi!

Doyon, Jean-Francois wrote:

So far, I've figured out I can go to portal_setup properties and change the
"active configuration" to the extension one.  I can then do an import of
that extension from the Import tab.  I then switch back the active
configuration.

This was working well when I only had one extension, but I now have two, and
what I've noticed is that no matter which I select, BOTH get installed!

They have different adapters, interface definitions, and everything.  And in
the log, only the one adapter claims to do an import ... Yet both show up!

Is this normal?  What am I missing?

What do you mean by "BOTH get installed"? Settings from two different profiles are imported at once? That sounds strange.

Also related, what exactly is meant by "active site configuration" anyways?

"active site configuration" is the profile used by the import tab. But the import tab shows *all* registered handlers, not just those useful for the "active site configuration". If you run the steps each step looks for related configuration files in the "active site configuration" and if it can't find them it does nothing.

Switching to a new "active site configuration" also registers the import and export handlers specified in the profile. That way you can register new handlers for export without overriding your site settings by an import.


I'm not happy with the setup tool and its user interface. It is still almost the same as in CMF 1.5, all the work done on GenericSetup was focused on improving the setup handlers.


HTH,

        Yuppie

_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to