Jens Vagelpohl wrote:
> Just out of curiosity, which dependencies does Plone 3.0 have that
> require Zope 2.10? Or was it some papal edict to use 2.10?

It was more of an edict, to catch up with the latest versions of our
underlying frameworks again.

The two things we are actually relying on right now is OOTB support for
egg-enabled Python packages instead of Zope products (there are some
egg-enabled plone.* and plone.app.* packages) and quite some of these
packages are using the new local components API.

We are also going to use formlib based forms, contentmanagers and
viewlets and finally zope.testbrowser based tests but these are
available in Zope 2.9 with Five 1.4 as well.

Apart from these supporting only Zope 2.10 made it possible to remove
quite some BBB code for changed package locations ;)

As a final note I might add that we still consider to support Zope 2.11
as well for Plone 3.0 especially if it brings us Blob support on the
ZODB level.


Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to