Previously yuppie wrote:
> Well. The 2.1 changes are based one the assumption that we switch 
> quickly and completely to utilities, making all tools work as utilities. 
> The roadmap proposed by Tres means it will take several years and we'll 
> have to work with tools and utilities side by side for a long time.
> I can live with that approach, but would like to see CMF 2.1 adjusted:
> 'getToolByInterfaceName' is a completely misleading method name if tools 
> will not become utilities. This method has no 'context' (or 'REQUEST') 
> argument, so it can't return tools. It returns utilities. 
> 'getUtilityByInterfaceName' would be a much better name for a 
> 'getUtility' replacement used in untrusted code.
> I propose to run a search 'n' replace *before* the next beta.

Done. I kept getToolByInterfaceName as a wrapper around
getUtilityByInterfaceName with a deprecation warning to keep backwards
compatibility with the last releases.


Wichert Akkerman <[EMAIL PROTECTED]>    It is simple to make things.                   It is hard to make things simple.
Zope-CMF maillist  -

See for bug reports and feature requests

Reply via email to