Previously Tres Seaver wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> I get the follwing failures:
> 
> 
> Error in test test_createSnapshot_default
> (Products.GenericSetup.tests.test_tool.SetupToolTests)
> Traceback (most recent call last):
>   File
> "/home/tseaver/projects/Zope-CVS/Zope-2.10-branch/lib/python/Testing/ZopeTestCase/profiler.py",
> line 98, in __call__
>     testMethod()
>   File
> "/home/tseaver/projects/Zope-CVS/pastest/Products/GenericSetup/tests/test_tool.py",
> line 697, in test_createSnapshot_default
>     result = tool.createSnapshot( 'default' )
>   File
> "/home/tseaver/projects/Zope-CVS/pastest/Products/GenericSetup/tool.py",
> line 443, in createSnapshot
>     messages[step_id] = handler(context)
>   File
> "/home/tseaver/projects/Zope-CVS/pastest/Products/GenericSetup/components.py",
> line 257, in exportComponentRegistry
>     sm = getSiteManager(context.getSite())
>   File
> "/home/tseaver/projects/Zope-CVS/Zope-2.10-branch/lib/python/zope/component/_api.py",
> line 48, in getSiteManager
>     raise ComponentLookupError(*error.args)
> ComponentLookupError: ('Could not adapt', <Folder at /site>,
> <InterfaceClass zope.component.interfaces.IComponentLookup>)
> 
> 
> and 11 more just like it.  Does anybody have a clue what is wrong?  This
> is with a fresh checkout, in an instance which has no other products
> installed.

Seems to work for me using Zope 2.10.4:

[snow;..l/instances/cmfout]-143> bin/instance test -s Products.GenericSetup
Running tests at level 1
Installing GenericSetup ... done (0.011s)
Running unit tests:
  Running:
.................................................................................................................................................................................................
  Ran 193 tests with 0 failures and 0 errors in 0.979 seconds.
Running Products.GenericSetup.testing.ExportImportZCMLLayer tests:
  Set up Products.GenericSetup.testing.ExportImportZCMLLayer in 0.932 seconds.
  Running:
..........................................................................................................................................................................................
  Ran 186 tests with 0 failures and 0 errors in 1.505 seconds.
Tearing down left over layers:
  Tear down Products.GenericSetup.testing.ExportImportZCMLLayer in 0.001 
seconds.
Total: 379 tests, 0 failures, 0 errors

Did something change in the Zope 2.10 branch?

Wichert.


-- 
Wichert Akkerman <[EMAIL PROTECTED]>    It is simple to make things.
http://www.wiggy.net/                   It is hard to make things simple.
_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to