Hi!

setup.py says:

       install_requires=[
         'setuptools',
         'zope.component < 3.5dev',
       ],

But CHANGES.txt says:

* Rewrite PersistentComponents.registeredUtilities to not use
   internal methods. This makes it compatible with both zope.component 
<3.5.0dev
   and >3.5.0dev.
   [wichert]

AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are 
currently failing, but they just show different, not broken behavior.


I'd like to change install_requires to 'zope.component < 3.6dev' and 
make tests work with zope.component 3.5.1 and older versions.

Any objections?


Cheers,

        Yuppie

_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests

Reply via email to