Tres Seaver wrote:
> Wichert Akkerman wrote:
>> Previously yuppie wrote:
>>> setup.py says:
>>>
>>>        install_requires=[
>>>          'setuptools',
>>>          'zope.component < 3.5dev',
>>>        ],
>>>
>>> But CHANGES.txt says:
>>>
>>> * Rewrite PersistentComponents.registeredUtilities to not use
>>>    internal methods. This makes it compatible with both zope.component 
>>> <3.5.0dev
>>>    and >3.5.0dev.
>>>    [wichert]
>>>
>>> AFAICS the 1.0 branch works fine with zope.component 3.5. Two tests are 
>>> currently failing, but they just show different, not broken behavior.
>>>
>>>
>>> I'd like to change install_requires to 'zope.component < 3.6dev' and 
>>> make tests work with zope.component 3.5.1 and older versions.
>>>
>>> Any objections?
> 
> I would just rip out the version requirement altogether (I did this the
> other day when testing CMFCore against the Zope2 trunk).

Some fixes in GenericSetup 1.5 just work with zope.component >= 3.5.0, 
so there is a need for a five.localsitemanager version that works with 
zope.component 3.5 *and* Zope 2.10/2.11.

I haven't tested if zope.component trunk can be used with Zope 2.10 and 
I can't see a need for supporting that combination.

For Zope 2.12 we will have five.localsitemanager 2.0, so I can't see a 
need to use five.localsitemanager 1.x with Zope >= 2.12.

five.localsitemanager trunk (2.0) has no version requirement specified.

Cheers, Yuppie

_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests

Reply via email to