On Fri, Jun 10, 2005 at 02:21:32PM -0400, Paul Winkler wrote:
> Done.  Like I said, just trivial docs typos.

While I'm at it, anybody object to the attached patch to
doc/FAQ.txt ?

-- 

Paul Winkler
http://www.slinkp.com
Index: FAQ.txt
===================================================================
--- FAQ.txt     (revision 30745)
+++ FAQ.txt     (working copy)
@@ -194,7 +194,35 @@
        (yay) it's var/z2.pid, for pcgi (not so yay), it's
        var/pcgi.pid.
 
-    4. After moving my old Data.fs to Zope 2.8 I get an 
+  Upgrading from Earlier Versions of Zope
+
+    1. How can I upgrade to Zope 2.8?
+
+       The usual procedure when installing a new version of Zope is:
+
+       - Create a new instance (see doc/INSTALL.txt).
+
+       - Copy the var/Data.fs file from your old instance into your 
+         new instance's var/ directory. (It is best to do this while
+         the old instance is not running; alternatively, you can
+         use repozo.py as described at 
+         http://www.zope.org/Wikis/ZODB/FileStorageBackup 
+         to make a live backup, then create a new Data.fs from that
+         backup in your new instance.)
+
+         Keep your old Data.fs in the old instance as a backup.
+         
+       - Copy the Products and Extensions directories from your old 
+         instance into the new instance.
+
+       - Update etc/zope.conf with any changes you made in your
+         old instance.  (Likewise for zeo.conf if you are using zeo.)
+
+       - Start the new instance. (Be sure the old instance is not running.)
+
+       - Update any ZCatalogs as described below. 
+
+    2. After moving my old Data.fs to Zope 2.8 I get an 
        "AttributeError, _length" when trying to use the ZCatalog?
 
        In Zope 2.8 we cleaned up the index implementations and therefore
@@ -224,6 +252,25 @@
           converted and reindexed"
 
 
+    3. CMF doesn't work!
+
+        Check that you have a recent stable version of CMF.
+        You need at least CMF-1.4.8.  CMF is available at
+        http://www.zope.org/Products/CMF/
+
+
+    4. Plone doesn't work!
+
+        As of the release of Zope 2.8.0, Plone does not support
+        Zope 2.8 yet.  Check http://www.plone.org for updates.
+
+
+    5. I'm using Python 2.4 and I'm having a problem...
+
+       Zope 2.8 has not been tested with Python 2.4.
+       Please use Python 2.3.
+
+
   General
 
 
_______________________________________________
Zope-Coders mailing list
Zope-Coders@zope.org
http://mail.zope.org/mailman/listinfo/zope-coders

Reply via email to