I am new to the world of Zope and Plone. I am trying to
the ZMySQLDA database adapter to connect Zope to MySQL. I am
Zope on a RedHat 9.0 Linux box. I have mysql version 3.23.58
came originally with RH 9.0). 
I have Zope version 2.7.5 (and Plone 2.0). 
I downloaded the driver: MySQL-python-1.0.0.tar.gz
and extracted the MySQL-python-1.0.0 directory to my
/usr/lib/plone2/lib/python/Products folder (Is that right?) 

I also tried /var/lib/plone2/main/Products where I normally
my plone products. ('main' is the instance that I am running)

then I did a cd to the  MySQL-python-1.0.0 directory and 
inside that directory, I ran the following commands:

 $ export mysqlversion="3.23.58"
 $ export mysqlclient="mysqlclient_r"
 $ export mysqloptlibs="ssl crypto"
 $ python setup.py build
 $ su
 # python setup.py install

After that I downloaded ZMySQLDA-2.0.8.tar.gz and extracted it
in the
same Product folder which created a ZMySQLDA folder inside the
Products folder. Some installation instructions talk about using
makefile from the 'src' directory inside this, but I don't see a
'src' folder inside it. I am assuming that it is precompiled. 
Also the python version (2.3.5) that I used to run the setup
file is
the same on which Zope2.7.5 was built. 
After all this I see ZMySQLDA as a BROKEN product in my Product
management interface with the following message:

Import Traceback

Traceback (most recent call last):
  File "/usr/lib/plone2/lib/python/OFS/Application.py", line
654, in
    product=__import__(pname, global_dict, global_dict, silly)
line 91, in ?
    import DA
  File "/usr/lib/plone2/lib/python/Products/ZMySQLDA/DA.py",
line 92,
in ?
    from db import DB
  File "/usr/lib/plone2/lib/python/Products/ZMySQLDA/db.py",
line 89,
in ?
    import _mysql
ImportError: _mysql: init failed

Am I missing something very important here. If yes, kindly let
know. Thanks.

- Nilesh

Yahoo! Mail
Stay connected, organized, and protected. Take the tour:

Zope-DB mailing list

Reply via email to