I am trying again to install MySQL-python-1.2.2 on a Solaris10 machine, but I 
have some installation problems when I 
"# /opt/Plone-2.5.2/Python-2.4.4/bin/python setup.py build":


running build
running build_py
copying MySQLdb/release.py -> build/lib.solaris-2.10-sun4u-2.4/MySQLdb
running build_ext
building '_mysql' extension
gcc -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC 
-Dversion_info=(1,2,2,'final',0) -D__version__=1.2.2 
-I/opt/Plone-2.5.2/Python-2.4.4/include/python2.4 -c _mysql.c -o 
build/temp.solaris-2.10-sun4u-2.4/_mysql.o -mt -D_FORTEC_ -xarch=v9
gcc: warning: `-x arch=v9' after last input file has no effect
cc1: error: invalid option `t'
error: command 'gcc' failed with exit status 1


On my pc I have:

- MySQL 5.0.27 (From the binaries for solaris 10 
mysql-max-5.0.27-solaris10-sparc-64bit.tar.gz provided in the mysql site. I 
have not been able to install from sources or with pkg).

- Python 2.4.4 (from the Plone 2.5.2 package)

- gcc 3.4.6

I think that maybe the problem is that MySQL is compiled whith a compiler 
different than gcc... and the problem could be solved installing MySQL from 
sources, but I not yet been able to do it.
Somebody have some suggestion?
Thank you in advance!


Zope-DB mailing list

Reply via email to