Hi there ...

I recently was looking at trying to transition to using psycopg2 from
psycopg, and installed that in a Zope instance (2.9.4-final, I realized
that's old).  The problem is that it doesn't seem to like my connection
strings (well, that might not be the problem as I get the same error even
with leaving that blank).  This is using psycopg2-2.0.6b2. A traceback:

2007-10-30T14:19:33 ERROR Zope.SiteErrorLog
Traceback (innermost last):
  Module ZPublisher.Publish, line 115, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 41, in call_object
  Module Products.ZPsycopgDA.DA, line 66, in manage_addZPsycopgConnection
  Module Products.ZPsycopgDA.DA, line 86, in __init__
  Module Products.ZPsycopgDA.DA, line 101, in edit
AttributeError: set_type_casts

I should note that going in via the python shell works.  I was able to
create a connection and extract data from a table that way.

Any ideas?  Is 2.9.4 too old for this version of psycopg?  I don't see any
note of this (except a mention in the psycopg2 FAQ which indicates that it
should work fine, but I know those sorts of things don't always stay up to


Zope-DB mailing list

Reply via email to