Yep, trying to access a newly instantiated empty zclass instance
produces the same error. 

Looks like a bug. Email me if you want an exported version of my zclass
to poke and prod at...

Tres Seaver wrote:

> Does the problem repeat in the "vanilla" version if you just create a
> new instance of your ZClass, instead of importing the old pickle?  If
> so, it is definitely a "bug";  if not, it may be a "migration problem,"
> with a fix like the one Brian posted for recursively "re-ownering"

> > If I take out manage_tabs from the offending ZClass index_html
> > method, I can view index_html (but of course, I can't use the
> > management stuff built in! making it rather useless), so that's
> > where we're getting into trouble for sure.
> > 
> > I've tried starting out with a vanilla 2.2a1 Data.fs and importing all
> > the zclasses and the relevent folders - no difference.
> > 
> > Anyone else seeing this?
> > Is this worthy of the collector?


Dr Ross Lazarus
Associate Professor and Sub-Dean for Information Technology
Faculty of Medicine, Room 126A, A27, University of Sydney,
Camperdown, NSW 2006, Australia
Tel: (+61 2) 93514429   Mobile: +61414872482  
Fax: (+61 2) 93516646   Email: [EMAIL PROTECTED]

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to