I just installed 2.2.0alpha1 onto an NT machine that already had 
two copies of Zope running happily on it. The new copy of Zope 
refuses to start with the following traceback:

Traceback (innermost last):
  File "<stdin>", line 1, in ?
  File "z2.py", line 524, in ?
    import ZServer
  File "D:\zope2\ZServer\__init__.py", line 123, in ?
    from HTTPServer import zhttp_server, zhttp_handler
  File "D:\zope2\ZServer\HTTPServer.py", line 116, in ?
    from HTTPResponse import make_response
  File "D:\zope2\ZServer\HTTPResponse.py", line 97, in ?
    from PubCore.ZEvent import Wakeup
  File "D:\zope2\ZServer\PubCore\ZEvent.py", line 91, in ?
  File "D:\zope2\ZServer\medusa\select_trigger.py", line 103, in 
    a.bind (self.address)
  File "<string>", line 1, in bind
socket.error: (10048, 'winsock error')

I ran it under pdb and it is trying to bind a socket to, port 
19999. Zope 2.1.6 had this code inside a loop so that if the bind 
failed it subtracted 1 from the port number and then tried again until 
it found a free port (or gave up after trying 50), but the loop has 
been removed in the new release.

(copied to the Collector)
Duncan Booth                                             [EMAIL PROTECTED]
int month(char *p){return(124864/((p[0]+p[1]-p[2]&0x1f)+1)%12)["\5\x8\3"
"\6\7\xb\1\x9\xa\2\0\4"];} // Who said my code was obscure?

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to