At 01:51 AM 6/2/00 -0600, Bill Anderson wrote:
>"Phillip J. Eby" wrote:
>> LM 0.8.6 also works with Zope 2.2 as far as being able to be added,
>> although I'm not sure it interoperates properly with the new security API.
>> It will still be backward compatible with Zope 2.1.6 either way, though.
>Hmmm ... just tried it on a fresh (Thursday) CVS dump, and get a no-go:
>Error Type: KeyError
>Error Value: _owner

Thanks for the heads-up, but it worked with the current CVS as of the
release of 0.8.6.  It's going to be a little while before we can take a
whack at it again.  2.1.6 is our primary development platform for both
ZPatterns and LoginManager.  When we do releases, we check them against the
latest CVS of Zope for compatibility, but it's something of a pain as we
have to do a certain amount of conditional coding to deal with the presence
or absence of 2.2 API's.  This is more a problem with LoginManager,
although ZPatterns is about to have some conditional code added to work
with Jim's new __get/set/delattr__ support (which, if it works, would mean
the DynPersist module would not be required for 2.2).

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to