>     TJM> That did it!  But...  :) I ended up having to re-create all
>     TJM> my ZSQL methods, which was funny because they all worked in
>     TJM> the beta 1 but not in beta 2.  I kept getting len() of
>     TJM> unsized object errors.  Anyway, re-creating them all from
>     TJM> scratch (ugh..)  solved that problem.
> So - any news on the re-creating all the sql methods bit?  I am about
> to start doing the same thing.  Any way to work around this?

You certainly shouldn't have to do that - AFAIK, TJ's was the 
only report of that behavior. There ARE other people reporting 
something about "len of unsized object" errors with their SQL 
methods after upgrading that I'm trying to get to the bottom of. 

Unfortunately, I haven't been able to reproduce that locally. I 
would really appreciate if some folks would:

  o !!backup your original Data.fs!! before trying out 2.2 beta 2

  o If you have any problems with the SQLMethods, if you can send 
    me your zipped object db (and info on what products need to 
    be installed to reproduce your environment) that would help a 
    lot. (send a copy of the back up Data.fs)

It would be great if someone can send me one where the SQL stuff 
is based on Gadfly or MySQL connections if possible...

Brian Lloyd        [EMAIL PROTECTED]
Software Engineer  540.371.6909              
Digital Creations  http://www.digicool.com 

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to